[SATLUG] Gaming: No Sound in America's Army 2.0.0a.

H. Streit hstreit at swri.edu
Wed Mar 31 17:37:44 CST 2004


Jeremy Mann wrote:
Platform: Dell Inspiron 8200 - Slackware-9.1-Current (as of 27mar04)
Window Manager: KDE 3.2.1

Okay,
	I got a wild hair the other night and downloaded America's Army 2.0.0a
for linux.  After reloading my Nvidia drivers (kernel compile gone wild,
wiped out OpenGL-something), the game runs.  However, I have no sound.
After fighting ArtsD for sound, I said to hell with it, dropped out of
X, configured FluxBox, and bounced back into X.  Still no sound.
'lsof|grep -i dsp' nothing. 'lsof|grep -i pcm' nothing.  I tried setting
a value for 'PreferredDevice=' in the $ARMY_OPS_HOME / System /
Default.ini file, but I still get nothing.  The docs that came with the
game *really* suck (troubleshooting for DirectX is in there...heh).
However, I found someone on the AAFiles.com site's forums that's having
the same problem.  But I don't think he's tried as much as I have to get
this going.  By the way, after my last recompile failed, my alsa-config
script dissapeard too...weird.  Anyone have any idea what's going on?


Stupid question, but have you checked your mixer settings? If your ALSA
config file is gone, then its probably reverted back to mute. To save a
state do this:

run alsamixer, set your volumes, hit ESC to exit, then run:

alsactl store

Also it would be nice to know if artsd is still running AND if you can play
other sounds like well.


Jeremy,
	Nuts.  I thought I had mentioned that.  XMMS works fine and KDE's suit 
of sound effects play like a champ.  Although, I have noticed that I 
have to fire up Aumix and adjust the PCM value +/- 1 before I can hear 
anything. (It displays the current value, but isn't actually set at it, 
I guess.)
	I'll try again tonight and see if I can nail this puppy.  I *really* 
want to know what the Drill Sargent is saying.  I wish the had subtitles....
	As far as ArtsD running and playing other sounds.  XMMS only works if 
the ArtsD plugin is added or it's configured for ALSA directly.  Usually 
for Quake3, I have to kill ArtsD before I can get sound.  I never 
bothered to figure out what was wrong, but it's a work-around...


More information about the Satlug mailing list